Solr – Error 401 require authentication

Problem Symptom: Whenever you are performing indexing from backoffice, you will get 401 authentication error.

Indexing failed19.09.2018 10:03:47: ERROR: org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException:

Error from server at https://localhost:8983/solr: Expected mime type application/octet-stream but got text/html. <html>

<head>

<meta http-equiv=”Content-Type” content=”text/html;charset=utf-8″/>

<title>Error 401 require authentication</title>

</head>

<body><h2>HTTP ERROR 401</h2>

<p>Problem accessing /solr/admin/cores. Reason:

<pre>    require authentication</pre></p>

</body>

</html> …

19.09.2018 10:03:47: WARNING: Error during indexer call: TrainingFacetSearch

 

Steps to resolve: 

  1. In most recent versions of Hybris, Solr expects you to fill out the solrclient and solrindexingclient credentials.
  2. Update the solr.impex file as below:solr-client
  3. Run the solr.impex file from hac or update the respective extension from hac.
  4. After update, backoffice solrserver configuration would look like this:solr-backoffice
  5. Perform indexing from backoffice. you should see no-errors now.


Categories: How-to articles

Tags: , , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: